Wipers Problem

Go down

Wipers Problem Empty Wipers Problem

Post by RichK on Sun Dec 10, 2017 8:55 pm

I cant get my wipers to work on auto, don't think i've changed any setting but if I turn the stalk to auto it gives one wipe then nothing, and this is in rain. Tried turning the bezel up and down and nothing, I have to click it down to normal wipers as couldn't see out of windscreen. Used to be ok but seems to have happened about same time as my auto light problem where they come on even on a bright sunny day.

RichK

Posts : 187
Join date : 2015-05-19
Location : Worcestershire

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by Rattly on Sun Dec 10, 2017 9:02 pm

There isn't anything blocking the sensor? If not it may be faulty!
Rattly
Rattly

Posts : 252
Join date : 2017-01-24
Age : 62
Location : Wales

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by Admin on Sun Dec 10, 2017 9:52 pm

With your auto light and auto wiper issues i would say you have an issue with the sensor's located near the rear view mirror
If i recall you have had the screen replaced, could be a simple connector loose, or even the replacement screen not compatable with the sensors? I insisted on a genuine screen in my SZ5 and had no issues

Karl
Admin
Admin
Admin

Posts : 1955
Join date : 2015-05-03
Location : SHROPSHIRE UK

http://vivavitara.forumotion.co.uk

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by STDI on Mon Dec 11, 2017 8:04 am

You asked the same here:http://vivavitara.forumotion.co.uk/t863-auto-wipers  My answer was a link to:Programming wipers and light.
Follow the instructions of how to program your wipers and lights. That might solve the problem.

STDI

Posts : 190
Join date : 2017-04-15
Location : Sweden

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by RichK on Mon Dec 11, 2017 9:52 pm

Did attempt the re-programme but got a bit baffled, in part one it says put wiper switch to off and wiper motor to auto stop, what is auto stop, also what do they mean by in section two by with engine switch in on mode, does that mean start the engine ?

Did think about the new windscreen but has been fine until now, maybe cold affecting the sensors ?, the area is clean. Can see this getting tricky if that is the problem with Suzuki blaming the new screen and screen company blaming the sensors. Will have another attempt at the program when its milder as says not below 5 degrees.

RichK

Posts : 187
Join date : 2015-05-19
Location : Worcestershire

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by RichK on Wed Dec 13, 2017 2:44 pm

I think its a sensor problem because if I put wipers on auto when raining it gives one sweep then nothing but if I tap the plastic sensor cover it gives about four intermittent sweeps then stops again until I tap it again. Would a replacement screen come with sensors attached or would the screen fitter have to refit the original ones does anyone know ?

RichK

Posts : 187
Join date : 2015-05-19
Location : Worcestershire

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by RichK on Wed Dec 13, 2017 4:30 pm

Update, Autoglass sending a warranty technician out next week as she said new screens have a lifetime of owner warranty. She said if I took it to Suzuki and they know its a new screen they would just refer you back to them,

RichK

Posts : 187
Join date : 2015-05-19
Location : Worcestershire

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by RichK on Wed Dec 20, 2017 1:36 pm

Had Autoglass out and says when new screen fitted a small lug has broke off the bottom of the sensor holder so was not quite making a good enough contact with the screen. He had put some stuff on to hold it in place temporarily and ordering new sensors and holders.

RichK

Posts : 187
Join date : 2015-05-19
Location : Worcestershire

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by Admin on Wed Dec 20, 2017 1:59 pm

Glad you found out the problem Rich and it wasnt actually a failure.......something for other members to keep an eye on should they have a replacement screen at any time

Karl



Admin
Admin
Admin

Posts : 1955
Join date : 2015-05-03
Location : SHROPSHIRE UK

http://vivavitara.forumotion.co.uk

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by RichK on Wed Jan 03, 2018 12:48 pm

You have to laugh, Autoglass called to fit the part today. His first question (different technician) was what's wrong with it, to which I said sensor problem, after a frown and guiding me to the back of his van which had a very large Toyota box which upon opening contained a rear parcel shelf/load cover for some vehicle Laughing Re-ordered to be rebooked for a future visit, maybe i'll get a nice set of side steps next time Very Happy

RichK

Posts : 187
Join date : 2015-05-19
Location : Worcestershire

Back to top Go down

Wipers Problem Empty Re: Wipers Problem

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum